> А есть у нас кто-то, понимающий в PHP?, одну функцию надо поправить
 Trex Member is Offline
 Posted: 19-06-2021, 13:04 (post 1, #1125398)

Flooder

Group: Members
Posts: 10032
Warn:0%-----
Народ, нужна помощь дилетанту! Есть сайт на вордпрессе на php 5.x, уже давно надо перевести на 7.3/4/8.х, но тема, которая была выбрана, давно заброшена "производителем". Поставил плагин PHP Compatibility Checker и он выдал одну ошибку и 4 предупреждения. Ошибку я вроде нашел как исправить, а вот 4 одинаковых предупреждения выглядят так:
WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
Как правильно исправить эту строчку?
add_action('widgets_init', create_function('', 'register_widget("nimbus_about_me_widget");'));

Кстати, плагин по проверке, работает только до 7.3, а чем проверять на более новые версии, ибо и она подходит к "концу" через полгода?
PM Email Poster
Top Bottom
 Trex Member is Offline
 Posted: 22-06-2021, 17:12 (post 2, #1125408)

Flooder

Group: Members
Posts: 10032
Warn:0%-----
Апдейт : На руборде помогли :)
PM Email Poster
Top Bottom
Topic Options